Friday, April 1, 2011

Invalid URL Fix

Auctions for free stuff at Listia.com

A lot of you may have experienced the dreaded "Invalid URL" problem.  Mostly associated with any facebook.com games like Mafia Wars, Cityville, Farmville, etc.  I attempted multiple solutions to no avail.  Typically ipconfig /flushdns worked but did not permanently solve the issue.  

Do you have a Linksys router?  I own a WRT310n V2 and I believe this is the root of all my headaches.  Not only did I experience the Invalid URL issue but was redirected from facebook to myspace or another random website.  Let me share with you a fix that I believe solved all of my problems and hopefully it helps you as well!

Follow these steps:

Open Command Prompt


Type "ipconfig /all"


Scroll up and find the circled text (note: your numbers will be different)


Make note of the last two sets of numbers

Open your Network and Sharing Center


Select the internet connection that you use


Click Properties


Select Internet Protocol Version 4


Click Properties

Select the button "Use the following DNS server addresses"

Type in the last two sets of numbers that we took note of earlier


Select the checkbox "Validate settings upon exit"

Click "OK"

Now we will validate our fix:

Open Command Prompt again
Type "ipconfig /all"
Scroll up and find the same set of numbers again "DNS Servers"


You should only have two sets of numbers now.

Try accessing Facebook or a page that was giving you trouble before.
I hope this solved your problem!

Leave me some feedback! This is my first blog post

Until next time,
Mike

BTW I'm open to reasonable requests! :)

57 comments:

  1. Replies
    1. how it worked it still come up invailid url when i try to do facebook

      Delete
    2. www.www.facebook.com
      Works. No joke.

      Delete
  2. Gr33ko, you rock, dude! Thank you :)

    ReplyDelete
  3. I have a Linksys router and this worked perfectly for my laptop. However when I went to try on my desktop, I could not get a validation box for Internet Protocol Version 4 and still get the error on my deasktop for "invalid url".I don't want to mess too much with config but should I try Internet Protocol Version 6 and also change in there. Thanks!

    ReplyDelete
  4. Also would it have any effect if I configured my network settings using Google Public DNS or wold this really mess up my ISP settings?

    ReplyDelete
  5. Glad to see this is working for most of you!

    Retired Teacher:

    Changing your IP V6 settings will not have the same effect. That's odd that you have an option for IP V6 and not IP V4. What operating system are you using.

    Using Google's public DNS settings should also work without any problems.

    ReplyDelete
  6. G-Lock try using that 1 set of numbers in your IP V4 settings instead of the two mentioned above. Let me know if it works.

    ReplyDelete
  7. JLarez go back into your IP Version 4 settings and reselect "Obtain DNS server Automatically" selection. Then you will be back to normal.

    ReplyDelete
  8. Thanks Gr33ko! Unfortunately it didn't work for me. I'm trying to access the internet on my uncle's network (it works fine on my network) but I keep getting error messages. Any suggestions?

    ReplyDelete
  9. What kind of error messages are you getting? Also what type of router are you using?

    ReplyDelete
  10. Whenever I open my browser the page just won't load. My uncle uses an AT&T 2Wire.

    ReplyDelete
    Replies
    1. This is a fix that may work for other routers but it was mainly for linksys routers.

      Delete
  11. Didn't work for me either... I only had 2 sets of numbers when I did the first ipconfig, and then I had the same after. No change :( I have been getting messages about certificates not being valid too. Just not both errors at the same time. How come it starts to load and looks like everything is fine, then it gets "stuck", I reload the page and get the invalid URL error message.

    ReplyDelete
    Replies
    1. Try using the two sets that show up. If it still doesn't work let me know.

      Delete
  12. This works. Can finally sign in to ESPN.
    Thanks!

    ReplyDelete
    Replies
    1. Sweet! :) Gotta get that sports scoop!

      Delete
  13. Im letting you know this worked on my wife's and my pc s. So far no more "invalid URL" on FaceBook. We're also from Michigan but transplanted to Anchorage. Thanks.

    ReplyDelete
    Replies
    1. I'm glad this worked for you as well!

      Delete
  14. Not working on my pc either :( same situation as "e7efb05e-eaf1-11e0-9eba-000f20980440"'s above ^^^

    ReplyDelete
    Replies
    1. Try using the two sets that show up. If it still doesn't work let me know.

      Delete
  15. omg, so far, so good! I'ts only been 15 minutes, but so far....THANK YOU, you are my BEST FRIEND, I have been rebooting/resetting router for 6 months, knowing that was the problem, but not wanting to take the router off because of my iPad. THANK YOU THANK YOU THANK YOU. If it quits working, I'll come back and cuss. :)

    ReplyDelete
  16. it's STILL working, you 'da-MAN! I will dance at your next wedding! How on EARTH tho, did you ever figure THAT out???
    thank you again!!!

    ReplyDelete
    Replies
    1. Might be a while before I get hitched but I'll keep that in mind! :)

      Delete
  17. Made it as far as your second last image ... PLEASE have a look and let me know what I'm doing wrong http://screencast.com/t/YmrQv2vPFiq
    Many Thanks,
    michael

    ReplyDelete
    Replies
    1. Hello Interview Guy. I saw your video. What you have to do is double click local area connection like you did before and then double click Internet Protocol Version 4 or select it and click properties. Then follow along from there. If you have any more trouble let me know.

      Delete
  18. awesome! I have been looking for REAL fix for 2 years. finally.
    thank you, thank you thank you.

    ReplyDelete
    Replies
    1. I'm glad it worked for you too! :)

      Delete
  19. Hello, I would just like to say that I have been trying to find a solution to this problem for quite some time now. It is finally nice to find a solution and that was very easy to follow. Great job with use of pictures and explanation. Of course, thank you very much as well! I can finally stop having problems with some sites I have been having. You're awesome! :)

    ReplyDelete
    Replies
    1. You're very welcome! And thank you! hahaha

      Delete
  20. i have a lynksis router, but when i did the ipconfig /all it doesnt shoe the 2 sets of numbers under the ip, and ideas why?

    ReplyDelete
  21. Man I,m so happy that this worked I thought I was being monitored by somebody else, thanks a bunch man!

    ReplyDelete
  22. Is there a Mac equivalent for this fix?

    ReplyDelete
  23. Does this fix only affect the device I'm currently using (this laptop), or does it affect the wireless router, and therefore fix the problem for all users of this wireless router?

    ReplyDelete
  24. KRL MALUCO TE AMO FUNCIONOU AQUI, VINHA TENTANDO FAZIA MESES ARRUMAR ISSO E FUNCIONOU TE AMO

    ReplyDelete
  25. what if i already only had 2 sets of numbers but it did invalid url anyway?

    ReplyDelete
  26. Thank you, sir! I've been with this problem for like 5 months now and it totally solved it!

    ReplyDelete
  27. Thank you, so happy to have this problem fixed! I also was always fixing with rebooting, so glad this issue is solved!
    Thanks!

    ReplyDelete
  28. yipes..... seems almost impossible to do..... any easy solutions for someone who is not a puter programmer??

    ReplyDelete
  29. Thank you i didnt think it would work till i seen all the positive comments. now i dont have to worry about my facebook messing up again.

    ReplyDelete
  30. Have the same exact LinkSys router. Contacted Cisco. They were going to charge me for the answer. I told them this was a very well known problem, and why would they charge ME for THEIR error!?! The tech finally told me to update the firmware, which I did. And that did not solve the "Invalid URL" error on both my PC and my Mac. This all started when I got my Mac and had it go through the wireless router. Many, many folks with either a PC and Mac, or multiple PC's have this issue. I think it has to do with not being able to resolve the DNS with two different computers running through the wireless network. Thanks for your very explicit instructions. So far, crossing my fingers. I'm going to see if there is some what to duplicate this on my Mac. If anyone knows how to set the network on the Mac in this same manner, I'm all ears. Just need very specific instructions, since I'm new to the Mac.

    ReplyDelete
  31. Thank you. I have the same router and I tried what you described and it fixed the problem completely. It's been over a week now and I haven't had a single instance of invalid url or any other errors that I used to have multiple times a day. It was very frustrating and now I am at peace!

    ReplyDelete
  32. thank you sooo much! this had been so frustrating.

    btw, i had to reboot to get the ipconfig to recognize the change.

    ReplyDelete
  33. I first tried using the set of 2 numbers, but still had 3 in command prompt. changed it to the one above the two, and facebook is now working. also, only the one is showing in command prompt. thank you so much, this was so irritating

    ReplyDelete
  34. Same. invalid url's "CURSE" on the linksys router is back. hopefully another fix will be found

    ReplyDelete
  35. Thank you that was work for me. now i can play my poker again,,,,,thanks....God Bless You

    ReplyDelete
  36. Worked just fine for me. Keep sharing.. <3 <3 <3

    Here is my website: All Inclusive Honeymoon Packages

    ReplyDelete